Android Beta 1 Release state


I see some happy Apple users here, but Im eager to test it in Android
I guess running on two devices like Samsung Galaxy S5 (on Lineage) and ZTE Axon 7 would bring some “new light” (pun intended) into scanning.

Any Updates yet?


I can’t wait to test the Android version as well.
I understand that you don’t want to ship it until there is some form of stability


I’m working in the Android build right now! Things have been a little slower than expected over the past couple days because I’ve been spending more time wearing my customer support hat and less time wearing my developer hat. But the Android version should be out in the next 24 hours, and it will include bug fixes based on feedback from the iOS version! :slight_smile:


I’m starting to get jealous of the iOS guys and gals here as they are testing the app for almost 3 days :grinning:


Is this the best place to find out if Android version is released?


Hey guys. Apologies for the delay in the Android release. You don’t have to be too jealous of the people running iOS – a lot of them had major bugs with the first beta. So I’ve been using that feedback to make some improvements to the code before releasing the Android version. It’s just taken a little longer than I thought it would, especially combined with the amount of time I’ve been spending doing customer support, which I forgot to bargain for. Sorry for the delay! I promise it’s coming very soon.



No problem Abe,

I rather wait a bit and have some of the bugs gone (is the rumor true that you’re buying us al ice-cream to make the waiting easier? jk…)



I downloaded the app and installed it. But when I start the app the screen turns to black and nothing happens.


Received invite in the mail, clicked it, got a google message me telling I could ‘be a tester’,clicked it.
Then had to click to ‘download the app on the store’. This gave ‘not available’ with a retry button.

After +/- 5 minutes and retrying, it showed up in the store, downloaded, installed fine. Gave permission to storage as stated, fired it up.

Black screen.

Closed, restarted. Tried it a few times. Finally discovered that it was showing me the feed of the camera, just at like 1/4th of second of FPS (like , 0.25 FPS). really sluggish and slow (on a Galaxy S7).

It’s late and I need to go to bed :), but quickly held a strip of film up against my monitor as a light source and pointed the camera at it. With the sluggish speed it was pretty much impossible to frame and focus, but I did see the picture change to quite correct colors. Hope to try again tomorrow with proper lightbox and steady hands :).

Far from perfect, but it’s something! First steps are made!


I happily tried the app on a 120 Ektar film.
Sometimes it switches colors once it recognized a frame and 50% of the time it freezes when clicking on gallery icon. I gave the app manually permission to store, however I can only find the taken pictures elsewhere on my phone, If I share them with e.g. Photos. It’s a great journey, I hope to find out more tomorrow.


Same here with me. Black screen. OnePlus3


Black screen, if I touch the screen it closes the app


I’ve got beta version 0.1 installed on a Samsung S7. The app will show a dark gray screen for 10-20 seconds then crash. An error is generated “FilmLab has stopped.” I’m unable to scan film or proceed any further to try the app out.


My S7 did the same after the install (dark grey screen then crash). I closed the app, restarted the phone and it started to work but the refresh rate is so slow that it’s pretty much impossible to capture anything hand held. Also the app crashes when pressing the gallery icon. I’m sure these will be fixed by time we just have to be patient :slight_smile:


Running the app on a Sony Xperia, I’m seeing pretty much the same issues that iOS users reported early on: Constantly shifting between positive and negative view, and snapping only pictures of the film strip, i.e. no frames are spotted, just a photo of the strip is taken. This is the negative view then. I’ll keep trying, though…
Thanks, Abe, I think I’ll love the app, once issues get less :wink:


Black screen even after restart on OnePlus 3. Touching the screen crashes the app.
Also tried to test on my Nvidia K1 tablet. Looks better (magenta and green lines all over) but with no image from camera either.
Both devices are Nougat of course.


Hi everyone,

I just got the app downloaded this afternoon after Abe updated my email address so that I could access the app in Play Store. Once done, installation was a breeze without any snags.

Here’s a walk through of my experience so far -

Once launched, the app was hunting and although returning a preview image, moving in and out of focus and constantly switching between colour and black & white and positive & negative previews. The steadier the phone, which is a Huwaei P9, the better the preview image and eventually the app would lock on and return a scan. This suggested that stabilising the phone and fixing its position above the negative to lock focus would help to settle things down.

I’ve got a homemade rig that I’ve used in the past for DSLR negative scanning. Basically, it’s an old 35mm enlarger with the head removed and replaced with the top plate from a Manfrotto fluid head video monopod. All I needed to do was to add a mini tripod ball head with a mobile phone adapter to hold the Huwaei and I was ready to scan.

Below: My scanning rig. The light source is a cheap LCD light panel from Amazon raised up on a stack of DVDs.

As soon as the phone was stabilised and locked into position I immediately started to get consistent previews and the app stopped flipping between colour modes. More importantly, each preview image was automatically converted to a positive image. With a little trial and error, I was able to work out the optimal distance need in order to return an in focus preview. The only thing not working is frame edge recognition.

I’m not sure if I had any influence on the next step or not, but if I tapped the phone screen the image seemed to begin processing and the app moved to the output screen. That said if I didn’t tap the screen it eventually returned a scan regardless. At the moment all the scans are reverting to negatives. Of the two buttons that appear on the output screen, the share button works flawlessly and I’ve been able to upload my scans directly to Google Drive without any problems. I haven’t tested saving directly to my phone gallery but I assume that will work too. The button with the landscape icon doesn’t work at all.

Once I had the phone stabilised so the app stopped hunting the entire time and I’ve not had any crashes.

Below - The preview image once stabilised, automatically returning a positive image.

Below - There seems to be some vertical and horizontal distortion even though the negative is under glass to keep it flat.

Below - Once scanned the image currently reverts back to a negative.

Below - Final output.


The following images are the result what is my minimum post-production routine in Lightroom. Apart from obviously being flipped from negative to positive, I’ve adjusted exposure, clarity and contrast and applied sharpening. They’ve also been cropped and straightened. I spent no more than a minute or two on each image. This is line with what I do for my professional event and press images.

Even at this early stage in the development process, I’d be happy to use these scans as digital proofs. The quality is certainly good enough for Facebook and Instagram. If the photos aren’t sharp then it’s down to my crappy focusing and camera shake on the day.

The film is Ilford HP5 400 pushed to 3200

ps - The odd overlapped split image effect in the last photo happened in the camera. I didn’t have the frame fully advanced so again it’s not the app.

Hope this helps.



I got it loaded on my phone today (Galaxy S8+). It’s doing the black (brown?) screen thing and will sit there as long as I let it. If I tap the screen it will crash. I’ve restarted but no luck.


TL;DR unable to detect a frame.

Found time to test the App today on my Huawei P9 Smartphone and Huawei Media Pad 3 tablet, booth on Android 7.

Beside the always known issues as blank screen after 1st launch, colour flipping, very slow frame rate etc. I’m unable to get a frame detected by the app.

I’m using a LCD light tablet as light source.

tested multiple film stripes arranged, single one, landscape and portrait mode of the devices, darker room.

Just got the unconverted film stripe back every time. But could save it on my device :joy:.

Furthermore I can’t see any buttons or icons to close the App, I have to kill it via the app manager.


Hi Abe

Great to be able to test and work on this. Really pleased that I backed the app

Installed fine on my Samsung galaxy S7. I did have to manually set access to camera and galary though as it did not initially work and I was unable to save.

As stated elsewhere the frame rate is a little laggy.

Initial scans were hand held but I remembered I had a small tripod for mobile which has helped.

I notice there is a difference in focus between normal camera function and in app.

The following are a sekection of results.


This is a glass plate negative. As others have mentioned whilst previewing the image it generated a positive but saved it as a negative when I tapped the image on screen.


Again same type of negative but the app automatically captured this image itself. Each time this has happened it rightly converts it to a positive.


The next images are 35mm


Whilst resolution is low this is the image correctly adjusted. It is not in focus as mentioned before. The film is Kodacolor 200.


The second image is taken with camera the first is in app. This is the differing focal range I mentioned earlier.


Initial images are encouraging though and with the 35mm negatives the app is recognising and converting just need to adjust my focal range and will try my macro lens on the next batch.