FilmLab beta release 0.1.2 for Android


Hi guys,

I just released a small update for FilmLab for Android. It doesn’t have any new features, but it tries to fix some of the major device-specific bugs that were preventing FilmLab from working at all on some devices. If you were getting nothing but a gray screen before, or seeing extremely laggy video, please give this new build a try and let me know whether those problems are fixed. Thanks!

If FilmLab was already running on your phone, the only new change in this version is that I fixed a bug that was miscalculating tap position, which improves the chances you’ll get a correctly identified frame after you tap to capture.



Thank Abe.!
It works on my OnePlus 3T now. I tried it quickly (shooting from the hip as it were). When you tab the screen it takes the shot but wont revert back to the camera view after the frame is produced although the camera is still in use.
Restarting the app is the only thing that make it work again.

It produces some frames that were useful.

(sky was blown out in the original)

The sharing button works. The button next to it doesn’t work…

There is no going back and forth from negative to positive. Frame selection is still a bit hit and miss but a huge improvement.

It also works better on my samsung tab.

i use a tiktech LED tracepad. Which is bright enough but it has this honeycomb/perforated pattern. I worked around it by placing tracing paper on it and up de brightness and place the negatives on the tracing paper.

The set-up I used was hugely makeshift and won’t do Abe’s work justice. But just a way for me to check the new version. Will improve the setup and come back with examples.`

Update 2: Some frames turn into pictures. Some will just turn into a picture of the film strip (negative). Might have to do with the quality of the negatives though. Seems that some of the pictures are a bit washed out.


Thanks new update.
I report my situation,
ver.0.1 / only gray screen
ver.0.12 / video coming! but flicking display with negative image…

I am using Google Pixel (sailfish) android O beta DP4.
Anyway thanks again your hard work!


Galaxy S6 Android 7.0

Frame rate is still about 1.5fps. Both buttons work, but usually saves a positive rather than negative. Tap to save is also delayed at least 1.5 seconds. Sadly too laggy to even show an attempt.


Much improved performance on my Huawei P9

  1. No longer color flipping or hunting for an image.
  2. Able to handhold and return a sharp scan.
  3. Holds negative to positive conversion for black & white negs, though not for color.

Seems to still have difficulty in ‘locking-in’ on the color information of the negative, which might be why it doesn’t return a positive image when you hit scan. I need to test with my 'scanning rig’and see if this is still a problem once the phone is fully stabilized.

Below - Output as exported directly from the phone. No post production, other than rotating the scan to be portrait.

Below - The same image, but run through Snapseed. Exposure and contrast adjustments applied, but no additional sharpening. One point to note is that I’m having to manually desaturate the B&W scans in post-production. I’m assuming that eventually, this will be something you set in the app prior to scanning.

Great work Abe, it’s starting to feel like a ‘real’ app.


I just updated to 0.1.2 and I don’t get anymore gray screen crashes! Thanks for the update. Haven’t had a chance to scan any negatives yet but looking forward to it. I will note the FPS does seem very low.

Edit: I got to play with the app and scanned some negatives. The app scans the negatives but I cannot zoom in or do anything with the scan. The scans work 50% of the time. Maybe due to the focusing?Which seems to pulse. Either I get a positive or just a picture of the negative. If I want to redo the scan, I need to restart the app.

It’s definitely a great step up from the last update. Looking forward to the next one.


All rite. Great job Abe. Definitely great improvement. One plus 3 here finally could see camera screen. Was gray screen before. Now seeing what people were talking about. Sometimes flickers from positive to negative and back. Also taking shot of the frame which presented as positive in the main window after brief 10 seconds wait or so present negative picture (around 50/50 time). Most of the times frame is not identified and rather shown as picture.


I have frame recognition! It didn’t occur to me until late last night but I didn’t have to manually crop the scans from yesterday morning.

I ran a new set of tests this morning to confirm, and I’m getting frame recognition approx 70% of the time. The only problem is that it seems to be at the expense of focus.

If I bring the phone in close to the negative so that the preview fills more of the screen then the app will recognize the edge of the frame and scan accordingly. However, the sweet spot for edge recognition appears to be closer than the minimum focusing distance of the lens and so the resulting scan isn’t sharp. If I raise the phone to compensate, I’ll capture a sharper image but the app then reverts to scanning the entire strip.

Also if the phone isn’t perfectly level the app seems to struggle with locking onto the images and returning a well-exposed preview. This also might account for some of the edge distortion I was seeing when scanning with the initial version of the app. Whether the phone is level or not also seems to be a factor in whether or not the app returns a positive scan and color switching. I think it’s safe to say the closer to 90 degrees the lens is to the negative the better the preview and resulting scan.

Attached scans are direct from the app, without any post production or clean up.


Hi Abe/all,

Definite improvement in the previous version.

I am using Samsung Galaxy S7 with Android V7 software.

I have found the camera lag to have cleared and the image responds much quicker. I still do not see any visible UI or icons but when I tap the screen creates an image and offers the share and save to gallery icons.

However, when I wish to return to the scanning image I have to exit the app and then reopen it. If I do not do this the image that was last captured pre share/save is locked on the screen and I cannot refresh the view.

Once saved the images are appearing in my gallery.

I have tested it with a few different types of negative to get a feel for it. I have found that each type (35mm, 120 and glass plate negative) each have an optimum range where the app appears to have no issues converting once selected. Whilst outside this range the image captured reverts to a negative, despite the app correctly displaying it pre capture as a corrected image.

I have also tried a redscale film but this seemed to totally mess with the app and I was unable to get a clear image to capture.

The following is a glass plate image 4" x 3"

This is the same image, however, as I had captured the image outwith what seems to be an acceptable range for the app it reverted to a negative

What I have noticed is that the corrected images appear more pixelated than those not inverted.

The following image is Fujichrome T64 positive image. This is a 6cm x 9cm image.

The app has not altered the caputured image.

This is a standard 6cm x 6cm shot. The film used is Fujicolor Reala 100.

The app has correctly swithed the negative to a positive.

The following are 35mm films, which I have struggled with for a few reasons. Firstly I need to sort out the lighting in the room as with 35mm film I am getting a terrible reflection of the mobile phone when attempting to capture colour negatives (this has not been a notable problem with 120 or glass plate images. I will check the forum for any suggestions on this).

If I am capturing the image at a certain distance the image correctly converts, otherwise it produces a copy of the negatives.

This is Iflord Delta 3200 film

All said a much better improvement and a step in the right direction.



I’m using an LG G5 phone, and the latest FilmLab Version doesn’t crash any longer, great!

But, I cannot tap on the Screen to take the Picture but the shot is taken automatically - but without any Frame detection, this doesn’t seem to work yet. And like others report, it flickers between negative and positive.

The sharing button works just fine, but the other doesn’t – what is it supposed to do?

Looking forward to a new release!


To save the image locally, maybe see into your gallery …


Doesn’t do anything but a green screen on Galaxy Note 3.

Very disappointing. …


Thanks for letting me know. There are a couple of Android devices still having issues. The cameras on these devices seem to be sending video in slightly different formats compared to all other Android devices. I’ll do what I can to get it working!


I noticed that the Samsung S7 has some issues with the picture that is snapped.

First , what I’m talking about only seems to happen when you snap a picture and that filmlab recognizes the frame correctly. In other words, most of the time filmlab snaps a picture that stays a negative and doesn’t crop a frame . That’s a known issue.

But I’m talking about when I actually get a positive picture with the frame neatly cropped. The picture I end up with appears extremely low resolution and then IMMENSELY over sharpened.

The thing is, I’ve seen this behaviour with other camera apps on the S7. Most tools that use the camera2 API (and are capturing dng , don’t know if this is a thing ) suffer from this, like Open Camera.

If I capture dng with those tools the dng is ok so I never bothered how the jpgs look. But filmlab’s output seems to suffer from the same thing which is a pain in the *ss to what it does to a scan.

The native Samsung camera app doesn’t suffer from this, but Lightroom for Android also doesn’t suffer from it. I guess because those tools have their own custom dng->jpg pipeline. It seems that if a tool uses the Camera2 API (samsungs implementation of it anyway ) to capture dng and then generate a jpg, the output is wrong. So filmlab is not alone in this, it does render it useless though.

Btw, I’m not talking about “over sharpening as a matter of taste”, I’m talking about immensely, big time destroying the image kind of (large radius ) oversharpened.

I can send captured by other tools to show the problem. Filmlab is a bit of an issue since it seldomly detects a frame ok in the beta :).


I’m seeing the same thing. The default JPEG processing is really gross. I’m working on getting raw support into the next build - it’s a high priority to me since people are sharing JPEG output samples and they are looking really terrible :grimacing:

Thanks for comparing other camera apps, that’s good to know.


Tested today my 1st roll of 35 mm black and white film, brand was Agfa APX 100. In the rare cases FilmLab was able to catch a frame it got always multiple frames, 2 or 3 in a row. This time aren’t any additional notches viewable which could be the reason for this.


I am trying to run it on HTC 10 / Android 7, I get a grey screen with the text ‘Configuration change’ and it happens nothing, there is just a grey screen and app crashes later. Is there a workaround or fix for this problem?