FilmLab beta release 0.1.2 iOS


#1

Received email for update to 0.1.2 on iOS today. Launch TestFlight and the update appears.


#2

Quick run with this update and I can see that the frame recognition has improved a lot.

  • No flashing back and forth between positive and neg
  • Get’s a good frame and captures the positive much more frequently.

Will give it more of a workout later.

Abe, keep up the good work. I was encouraged with the first beta, more so now.


#3

Did you use a film holder?
Since I updated the app has trouble to locate the frame. It scans multiple frames.
I think that the film holder is the problem. I use the Lomography Digitaliza 35mm, which also show the sprocket holes.


#4

Using my same Porta-Trace light box and Beseler enlarger plate from the last test, this iteration was much more useable. I had little flashing back and forth from pos to neg (and it only occurred as I was getting the negative framed up). The frame was recognized accurately. Looks like the core functionality is there, Abe, congrats! Looking forward to seeing your refinements in the next few versions. It is certainly headed toward being a much faster workflow for me to “scan” negatives than setting up my tripod and using my digital!

Fuji Acros 100 6x7

Some blown highlights that have detail in the negative, but I’m sure that will improve with full res, raw processing, and refinement of the exposure algorithm


#5

Just gave the new beta a quick test. I’m using a real lightpad now (as opposed to my iPad) and that definitely helps.

The new beta seems to ‘settle’ on the correct colors much more quickly, so that’s definitely moving in the right direction.

I tried it with some color positives (transparencies) but it insisted on seeing them as negatives, and I couldn’t persuade it otherwise. I think the final version should perhaps include a switch for neg/pos, color/mono to help the algorithm search more efficiently. I could even imagine it having film profiles, so you could choose the particular film used (but maybe that’s better done in post-processing on the desktop).

With some of my color negatives, it seemed to find and display the correct colors quite quickly and accurately. When I touched the screen to scan the image however, it was something of a crapshoot: once, it produced an acceptable color positive image (a bit blown out, but that could be the original). Other times, I just got a photograph of the negative.

It’s pretty clear that it’s early days yet and that this is better described as ‘dev’ or ‘pre-alpha’ rather than ‘beta’ software, but that’s what we expected. It’s definitely moving in the right direction.

I wonder if it would give better results with some kind of stand to hold the iDevice steady and at a fixed distance from the film. I would think that hand-holding must lead inevitably to blur. Maybe someone will start a hardware Kickstarter for a FilmLab Stand/Scanning Station … :slight_smile:


#6

My experience is a little better from the last beta. I’m on an iPhone 6s and before I couldn’t get it to do anything.

Now I can snap one after some effort. I’m getting the same issues everyone else is, flipping back and forth, snapping a shot only to find it took a picture of the negative, etc.


#7

Here’s a demo (15 seconds video):

TikTech light pad, iPhone 7Plus. It’s the iPhone camera’s standard lens, not a macro add-on.

(The bright white light pad shows up as black as FilmLab inverts the image.)

170811-FilmLabBeta-Point2-Demo from Richard Karash on Vimeo.


#8

With the first launch using an Ipone7 and a light box I couldn’t get anything to capture very well. With the new update I was able to capture this from a reclaimed negative from a print of Fuji FB-100C. A little grainy, and not so clear. Any suggestions or just the nature of the beast this early on?

Here is a Google Scan of the print…


#9

Using 0.1.2 on SE and using that Big Ben? negative from Wikicommons. Often nothing happens. No recognition or change. Sometimes it recognizes the image then pulses on/off positive image but when I click on the image, a negative version is always saved. Not really working for me at all.


#10

iPhone 6s with IOS 10.3.3 I get the same issue.


#11

Hello!
Here is my feedback on the beta app v0.1.2

Hardware:
iPhone SE iOS 10.3.3
A3 Vario LED light pad
Film tested:
Kodak Portra 400 135
Kodak Ultramax 400 135

Film lab often doesn’t capture the image, even though the preview window is showing correctly inverted negative: All of the following images were captures when film lab was showing a correctly inverted image on the preview. The image to grab was touched but the app did not crop it and created a un-croped negative… This was more common in this version than the previous v0.1.1





The frame capture works well on some frames and very bad on others. When there is a dark area at the edge of a frame the cropping does not work at all. Some examples of frames that are impossible to capture:



Images are still overexposed but improved from V0.1.1
On occasion the app starts “pulsing” when in the preview window. When this happens it is not possible to capture a negative.
For me the app is working worse than v0.1.1 because it now frequently fails to capture an inverted image.

Should the app be used in portrait or landscape mode? I don’t see a big difference in testing.

some successful captures… (I did not have many with this version of the app)

Tim.


#12

I’ve tried both ways. Sometimes finds the frame, sometimes includes areas of the next frame.


#13

I have the same problem as Tim.

it didn’t flip between positive and negative as much now though


#14

The flashing is much improved, as others have noted, but I’ve had great difficulty capturing frames. FilmLab regularly selects 2.5 or 3 frames.

I tested iPhone 5 and 7. Happy to report that the 5 works just as well as the 7.

I wrote up some quick notes and posted images to my blog.
iPhones 7:

iPhone 5:

tl;dr almost impossible to find a frame. Tested half frame, normal 35mm, and panoramic images from a Speocket Rocket; 35mm color negative, black & white, and chrome; medium format color negative.

I probably need to spend more time with it.


#15

Thanks, guys, there are some really helpful bug reports in this thread. In particular, thanks for including the sample images, @Tim, and the details about what device(s) and film(s) you’re all using. Having that information is very useful to me.

The biggest problem in the current beta is definitely inaccurate/inconsistent frame detection, so that’s going to be my focus for the next few releases.

Thanks again to all of you for backing the project on Kickstarter - as you can see, there really is a lot of work to do to make this into a finished app, and it’s your support that’s making it possible for me to spend the necessary time to get everything working!


#16

Getting much better frame detection and color. Great work look forward to future releases.


#17

Sorry did not include my set up 1.iPhone 7 plus 2.Old Logan desktop light box 3.Film holder with 35 kodak negative films. A few photos from 0.1.2

IMG_0587


#18

I’m on the iPhone 7 plus and I’m still having frame ID and color issues.


#19

iPhone 7 Plus
iOS 11 b6

Cant capture a positive image from color negative, although the screen will display the image as a positive, the capture is consistently negative.

B&W negatives don’t work at all. Screen displays negative image.

Both could be related to backlight method or ios11…I have been using either iPad screen or MBP screen set to white. Ive tried multiple brightness levels and various distances.

Im having issues with multiple inadvertent captures just brushing the screen…this has occurred on both betas.


#20

Hello!
Here is my feedback on the beta app v0.1.2 using slides

Hardware:
iPhone SE iOS 10.3.3
A3 Vario LED light pad
Film tested:
colour slide film (unknown)

FilmLab app did not recognise that the image was positive and inverted it in the preview window. When captured the frame was not recognised and the whole image was stored in it’s original form. Not sure if this is meant to work yet?

Attached snapshot of app preview and output image…


Looking forward to the next release

Tim.


A good film holder