FilmLab beta release 0.1.2 iOS


Blown out highlights
I use:
iPHone 6s Plus
iOS 10.3.3.
Light source: Old Kaiser light table.
Ambient light: Some with daylight, some with dark room and some with indoor light.

I have the same problems that have been described by other user.
This time I want to comment on blown out highlights, as shown in uploaded pictures.
The negatives are OK. However, the scan comes with areas that are totally blank.
(Sorry for my English :slight_smile: )


Best regards


I’ve had mixed results with the new release although I have the feeling the overall experience still improved slightly. I found a curious little bug however :wink:
My setup:
iPhone 6s
iOS 10.3.3
App Release 0.1.2
Fresh Kodak Ektar 100
JUST Normlicht Fluorescent Lighttable

I tried scanning a new film from a recent holiday.
The first few frames the detection worked okay. It would only take 2-4 tries usually to get the app to recognize the correct frames. I also noticed that it would mostly either fail completely or get it right completely which I think is good. Would be more annoying if everytime you’d have to analyse the image to see if it’s usable or not.

Anyway, after a couple of frames The frame detection would not work anymore. Always the whole capture area with the colors not reversed. So I started shaking the phone wildly as I’ve noticed before that sometimes it helped when the app had a “fresh” look at the image. This didn’t help. So I tried closing the app with the app switcher while I was in the app. I opened it up again right away and noticed that filmlab was showing me it’s frame detection guidelines. I’ve captured a few screenshots.


Okay I think I found the issue in my case.
I thought it would be best to block most surrounding light to keep stray light to a minimum. So I placed some neoprene I had laying around above the filmstrip and a couple slide film strips below the filmstrip to be captured. When this arrangement is too close to the film then I guess filmlab has not enough white area around the frames which adds to the complexity. I moved them out by an inch and it seemed to work better right away. Attached some images to help show my setup:


Also to show why I already love this app, here some results where I think it performed extremely well.
Also I just thought of this but in my case theres a further issue for the app. I have my films dev’d only and not cut but instead placed into long tubes of protective sleeve which have an overlapping opening along the running edge of the filmstrip but it’s basically in the middle of the image. So on the upper part of the image there is two layers of the material and on the lower part only one.

Long story short: here are the images:


Another curious thing I noticed:
Sometimes the app will mirror the captured image horizontally. Here is a screenshot of the app in preview and one after tapping on the frame.


Finally I’ve been able to perform some tests.

Some general info:

  • I have worked in my darkroom in fully dark environment (lightpad and iphone screen excluded).
  • device is an iphone 7+
  • film is 35 mm illford FP4+ (black and white)
  • lightpad is KAISER slimlite plano (expensive but not flickering)
  • the device is hold on position usign a plastic box, the focusing distance is between 80mm and 100mm (i’ve use a book to add thickness for focus testing puorposes).


What I can say on frame recognition is the same other have already reported:
the app (at this point) often fails, usually framing only an half frame or a farme and a half.

Focusing is an hard task here; the web says the minimume focus distance for iPhone 7plus is 80mm,1mm less and it starts to get blurry,I’ve used a plastic box to hold the device to the correct distance BUT the (my?) films are a little bit curved than the plane son the central part of the film may result to a shorter distance and blurred.
To avoid this I’ve both tried to increase the film-device distance and to kee pt film flat framing it with some plastic.

increasing the distance does not fully solve the problem (you still have different distance between lens and different film areas)

keeping the film flat using plastic strips may somehow interfere with the frame recognition feature of the app (indeed I’ve not been able to get any automatic recognition when using plastic strips to hold the film flat)

I suggest to use a support that holds the device something like 85mm from the plane.


I would like to suggest some workflow improvements to @abe:

auto exposure in my opinion should be “per frame” before capture
"capture" should be slightly dalayed (milliseconds) from screen tap (to avoid micro blur if the device is on a tripod or other suport)

so maybe we can have:

  1. auto exposure on all area
  2. tap on the desired frame
  3. frame recogniction
  4. autoexposure on that frame
  5. capture

Light pad

The KAISER slimlite plano is expensive, but if you set it to maximum brightness you will have 0 flickering,
I’ve used the FLICKER TESTER app and here you can see the result:

The lightpad is dimmerable and if you use a minor brightness you will have fickering (amount seem proportional to brightnes reduction)

Light source suggestions

Note the ILFORD FP4 PLUS reversed type looks in focus

Frame correctly recognized!

Final Image correctly saved to camera roll!!!


Feature suggestion: If in doubt about frame, treat the whole image as a valid negative and process it.

Rationale: In my test samples, the most common problem is failure to recognize frame, and therefore not convert negative to positive. I can crop afterwards, but I can’t do the neg to positive conversion.

Keep up the good work Abe. I have high hopes for this product.


Secret debug mode unlocked! I was wondering when somebody would discover that. Yes, shaking the phone toggles a hidden debug mode. Currently this shows the outline of objects detected in the scene. This may change in future builds, but feel free to give your phone a shake and see what that reveals :grinning:

Yep, that’s a bug.

Thanks for taking the time to share your results! Those medium format images look good! Output quality should improve in the next build.


Makes sense. I wanted to see if I could simplify things down to two modes (overview -> captured), but in practice this is turning out to be confusing so I think the original prototype with three modes (overview -> selected frame -> capture) was better. I’ll be moving back in this direction soon.

Yes, frame recognition failure in the captured image is by far the worst problem in the current builds, because it means you get no useful output. I have a different solution mind, however: I’m working on auditing the ability to manually set/adjust the frame area after capture. More on this coming soon!


ok, Iphone se, negative black and white film.

I tested it out with a full white screen on the macbook pro, max intensity. Obviously, it blinks.

The app inverts the image but I can’t zoom in at all; if I tape, the app take a regular picture (non inverted).

If I use the “shutter” button, it just opens the library.

It does not recognize a frame at all.


I signed up for your Kickstarter for both android and iOS, but I haven’t received a email to download either Beta. I really have a need for the iOS version as I want to scan in some family photos for a relatives funeral in mid October. I have seen announcements about various beta releases in my email, but nothing on where to go and how to download it. Any help would be much appreciated


I still have the previous version (which didn’t work for me). Nothing to update. How come?


@Glennbkr1 you should download an app called testflight from the app store.
Once installed it will be the tool to have access to filmlab app beta.


Before, I couldn’t even get a good frame, it was always inverted now it’s only some of the time. The crop tool works but when it does, it produces an inverted image. The image is positive when you touch it and when you choose the crop tool, but after cropping, it comes out inverted.

Just thought I’d report.

I’m running an iPhone 6S with the latest release of IOS. I’m scanning on this:


Would you please give me an email for installation?