FilmLab beta release 0.2 iOS


Hey guys,
Here a short first test of my setup:

iPhone 6s
iOS 10.3.3
JUST Normlicht Fluorescent Lighttable
Kodak Ektar 100 Medium Format Film

The app now stays in the negative conversion mode, no more switching back and forth. Interestingly it does show flickering with the new build. 0.1.2 doesn’t produce these effects under the same circumstances. It doesn’t seem to have an impact on the final capture though.

The new UI is nice and switches without issues from landscape to portrait orientation of the phone.
The manual crop tool is such a help already. Now I don’t have to switch to another app after capturing a frame to clean up the crop.
I can even go back into it and keep adjusting the frame.

Colors seem almost identical, just in the upper left of the double exposure it seems it picked up more diverse colors.
On the second image I don’t understand why it forced such a strong color shift.

Resolution wise I can already see visible improvement of detail. Can’t wait for future builds to make full use of (multiple) raw capture.

I will keep trying over the next days and add to my first review.

Thanks a lot for the good work @abe !



Latest iPad, color correct professional lightbox with masked VPS 120 negative.

I am able with great difficulty to manually crop. Image converts to positive with poor color but probably correctable. I still cannot save images and the images are not in sharp focus. Curious about the sharpness, not using the app but using the iPad camera, I shot the neg and it was sharp.

Best regards,


Yasha, try using film lab to convert the sharp image of the negative.

FilmLab… Tap the “flower” symbol… Pick from any one of your photos. FilmLab should convert it if it’s a shot of a color negative.


just picked up some more film and wanted to add a few things I noticed.

Here again my setup:

iPhone 6s
iOS 10.3.3
FilmLab App v 0.2
JUST Normlicht Fluorescent Lighttable

When I open the app and load some already shot image with the flower button, hit the crop button and then turn my phone, it basically breaks the orientation mode of the app. So lets say I have the phone in portrait mode, i hit crop and then turn my phone to landscape and exit the crop mode using the crop button or the arrow button it goes back to the live camera feed but now everything is 90 degrees turned and there is a red square where normally the content would be. I checked, it even happens when I hold the phone in landscape with the home button on the left and turning the phone 180 degrees. Only now the live feed is obviously 180 degrees turned. I checked, it seems to be a reversible bug. So lets say I started with the home button on the left, turned it so it’s on the right and now everything is basically upside down in the live camera. When I do it again, home button on the right, turning so it’s on the left and exiting, everything is back to normal.

I’ve attached a picture of the UI clitch that happens when you turn the phone 90 degrees.

I hope I could make myself clear a little bit… can’t wait for iOS 11 so I can just screen record what’s happening…
Just wanted to hold off for a bit until most apps are compatible with it. How is Film Lab doing in that regard by the way?


Also some small things. I was trying to get a good mastershot of three film strips. I shot 2 images each 3x3 frames and 1 image 4x3 frames.
That way i could evaluate the auto whitebalance colors over a larger sample.
When I crop the three images and have the phone in landscape mode, the long panoramic image hides on the right under the diffused icon bar where the crop and export buttons are as well. It obviously doesn’t happen in portrait mode.


Question for @abe – Does having the unexposed film in the selected crop affect the auto elements of filmLab? (i.e. auto WB, exposure, color) Or should we be eliminating the unexposed film areas to get good color?


What I noticed, it seems like it needs a bit of it to judge the filmbase and to be able to correctly balance this out. Too much how ever definitely gives strong color casts. I guess at a certain point it interprets it as part of the image. Probably some kind of weighted center averaging calculation.
This should play into all three of the three mentioned criteria @ColSebastianMoran as they are kind of intertwined.


Currently the auto correction is analyzing the middle 80% of the crop area. So as long as you keep film borders confined to the outer edge, they will be ignored. Like many things in the current builds, this is a very simple implementation, which will be replaced with a more sophisticated solution later :slight_smile:


@abe That sounds good… Auto-correction analyses middle 80% of the crop area.


Why not make presets for the different film stocks so the color accuracy will improve and the app dosen’t have to figure this out on his own. I think I asked this already (but didn’t get an answer), are you planning to implemet apples AR Kit? I think this would be really great to detect surfaces and correct perspectives of the frame.


Anyone notice when you shake your device you get red and blue boxes attempting to identify the frames of negatives? Hidden feature or bug. Doesn’t seem to be too accurate.


Spotted it too. It’s a development feature to see right away how it’s picking up the frames. I think it actually helps as you know beforehand if your holding the device right. It depends on the film and the actual image (dark night scenes for example) obviously too.


Click here for a short demo movie, captured from iPhone screen as I use FilmLab on a frame of color negative film.

Some are having trouble getting the app to frame and capture. Keep at it; if it fails, try again. If the color is off, tap to capture anyway, then adjust the framing, FilmLab will re-convert.

In my movie, I’m getting about as big a capture as the close-focus limit allows. Any closer and it’s blurred.

Won't recognize the frame?

I upgraded to an iPhone X with the latest iOS version and have FilmLab 0.2 (4) loaded on it. Unfortunately the app crashes on opening. I’ve tried the usual stuff, shutting down and restarting both the app and the iPhone itself without luck.

Am I doing something wrong?



I also have iOS 11.1.2 and Version 0.2 of FilmLab but don’t habe the same issue. You said restarting didn’t help. There are some other resetting options with the iPhone if I’m not mistaken. Did you try those as well?


Hey - thanks for the reply. I’ve done all the usual tricks… shutting down and restarting the app, restarting the iPhone, resetting the iPhone. So far no luck. Everything was working on my 6S Plus, but when I moved everything to my iPhone X, it just shows a white screen and then it’s back to the screen full of apps.

Thanks Again though…


Did you try downgrading to the first iOS version? You can go back and forth easily with the testflight app.
Also an option is to delete the app and install it fresh.


Now that I did not know! I will try both options. Thanks very much.


Noticing that version 0.2 (4) expires in 16 days. That would be about December 13.


Thanks everyone for your help. Deleting the app and re-installing did the trick and now I’m back in business!

Thanks Again!